CVE-2026-44007: patriksimek vm2 · Improper Access Control
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.11.1 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade patriksimek vm2 to 3.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in vm2 version 3.11.1. Users should upgrade to version 3.11.1 or later to remediate the issue. No alternative mitigations are specified by the vendor advisory. Applications running untrusted code inside a NodeVM with nesting enabled should apply the update promptly to prevent exploitation.
Description
vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.1, when a NodeVM is created with nesting: true, sandbox code can unconditionally require('vm2') regardless of the outer VM's require configuration — including require: false. With access to vm2, the sandbox constructs a new inner NodeVM with its own unrestricted require settings and executes arbitrary OS commands on the host. Any application that runs untrusted code inside a NodeVM with nesting: true is fully compromised. This vulnerability is fixed in 3.11.1.
References
- github.com/patriksimek/vm2/security/advisories/GHSA-8hg8-63c5-gwmx (opens in a new tab)
- openwall.com/lists/oss-security/2026/05/05/11 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-44007 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477198 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44007.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:50850 (opens in a new tab)