Skip to main content
VulnerabilityPublished Updated

CVE-2026-44009: patriksimek vm2 · Resource Exposure

Affects patriksimek vm2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.11.2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade patriksimek vm2 to 3.11.2.

Affected software

ProductAffectedFixed in
patriksimekvm2Affected
  • <3.11.2
Fixed in
  • 3.11.2
npmvm2pkg:npm/vm2Other threatsAffected
  • <3.11.2
Fixed in
  • 3.11.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vm2 to version 3.11.2 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Users should apply the official fix promptly to prevent exploitation.

Description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.2, This vulnerability is fixed in 3.11.2.

References

Community reviews

Loading reviews…