CVE-2026-44029: NixOS Nix · Absolute Path Traversal
Affects NixOS NixSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium · fixed in 2.34.7 : update NixOS Nix when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.34.7, 2.33.6, 2.32.8 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NixOSNix | Affected
| Fixed in
|
| NixOSNix | Affected
| Fixed in
|
| NixOSNix | Affected
| Fixed in
|
| NixOSNix | Affected
| Fixed in
|
| NixOSNix | Affected
| Fixed in
|
| NixOSNix | Affected
| Fixed in
|
AI-suggested
Fixed versions are available starting with Nix 2.34.7 and earlier patch releases (2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7). Users should upgrade to one of these fixed versions to remediate the vulnerability. Patch status is not explicitly confirmed in the provided data; therefore, check the official NixOS vendor advisory for the latest remediation guidance and to confirm patch availability.
Description
CVE-2026-44029 is an absolute path traversal vulnerability in NixOS Nix versions prior to 2.34.7. It allows writing to arbitrary files via directory traversal when using the commands "nix-prefetch-url --unpack" or "nix store prefetch-file --unpack. " The issue affects multiple versions starting from 2.24.7 up to 2.34.0. The vulnerability has a medium severity with a CVSS score of 5.