CVE-2026-44198: wagtail · Improper Handling of Insufficient Permissions or Privileges
Affects wagtailSource GCVE Database
Not known to be exploited · CVSS 4.3 Medium : upgrade to 7.3.2 or 7.0.7 when convenient.
Data as of 27 Oct 2026, 00:44 UTC
- Patch
- Available – fixed in 7.3.2, 7.0.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade wagtail to 7.3.2 or 7.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wagtail wagtail | Affected
| Fixed in
|
AI-suggested
Upgrade Wagtail to version 7.0.7, 7.3.2, or 7.4 or later, where this permission handling issue has been fixed. No additional mitigation is required once patched.
Description
Wagtail CMS versions prior to 7.0.7, between 7.1 and before 7.3.2, and before 7.4 allow users without edit permissions to access the page history report. This improper handling of insufficient permissions could lead to disclosure of sensitive information. The issue is fixed in versions 7.0.7, 7.3.2, and 7.4.