CVE-2026-44237: FreePBX security-reporting · Weak Authentication
Affects FreePBX security-reportingSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 17.0.8 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 2.7% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.0.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade security-reporting and freepbx/security-reporting to 17.0.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreePBXsecurity-reporting | Affected
| Fixed in
|
GitHubfreepbx/security-reportingpkg:github/freepbx/security-reportingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in FreePBX version 17.0.8. Users should upgrade to version 17.0.8 or later to remediate this issue. Patch status is not explicitly stated beyond this fix version, so confirm with the vendor advisory for the latest remediation guidance.
Description
FreePBX versions prior to 17.0.8 contain a vulnerability in the api module's OAuth2 implementation where client credentials are not properly validated during token issuance. Specifically, the validateClient() method in ClientRepository.php always returns true, allowing an attacker who knows a valid client_id to obtain OAuth2 access tokens without the correct client_secret. This weakness enables unauthorized access to the system's OAuth2 tokens. The issue is fixed in version 17.0.8.