CVE-2026-44239: FreePBX security-reporting · PHP Remote File Inclusion
Affects FreePBX security-reportingSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 17.0.5 or 16.0.22 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.0.5, 16.0.22
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade security-reporting to 17.0.5 or 16.0.22; freepbx/security-reporting to 16.0.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreePBXsecurity-reporting | Affected
| Fixed in
|
| FreePBXsecurity-reporting | Affected
| Fixed in
|
GitHubfreepbx/security-reportingpkg:github/freepbx/security-reportingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in FreePBX security-reporting versions 16.0.22 and 17.0.5. Users should upgrade to these or later versions to remediate the issue. Since this is not a cloud service, patching the affected software versions is required. Patch status is not explicitly stated in the vendor advisory, but the description confirms the fix is included in these versions.
Description
FreePBX is an open source IP PBX. Prior to 16.0.22 and 17.0.5, the Dashboard module's getcontent AJAX handler includes PHP files based on user-supplied input without path sanitization. The $_REQUEST['rawname'] parameter is concatenated into an include() call with a .class.php suffix, allowing path traversal via ../ sequences to include arbitrary .class.php files from the filesystem. The included file's PHP code executes before the subsequent class instantiation error occurs. This vulnerability is fixed in 16.0.22 and 17.0.5.