CVE-2026-44262: dedoc scramble · Code Injection
Affects dedoc scrambleSource CVE Database V5
Public exploit available (Exploit-DB) · CVSS 9.4 Critical : upgrade to 0.13.22 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 5.8% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.13.22
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:LExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: evidence found.
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 7 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 25 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
scramble - Remote Code Execution
, 15 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade scramble and dedoc/scramble to 0.13.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dedocscramble | Affected
| Fixed in
|
GitHubdedoc/scramblepkg:github/dedoc/scrambleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerability is fixed in dedoc scramble version 0.13.22 and later. Users should upgrade to version 0.13.22 or newer to remediate this issue. Patch status is not explicitly confirmed in the vendor advisory, but the description states the issue is fixed in version 0.13.22. No other mitigation or temporary fixes are provided.
Description
CVE-2026-44262 is a critical code injection vulnerability in dedoc's scramble tool versions 0.13.2 up to but not including 0.13.22. The vulnerability arises when documentation endpoints are publicly accessible and validation rules incorporate user-controlled input, enabling arbitrary PHP code execution during API documentation generation. This flaw has a high CVSS score of 9.4, indicating severe confidentiality and integrity impacts. The issue is fixed starting from version 0.13.22.