CVE-2026-44288: protobufjs protobuf.js · Improper Handling of Unicode Encoding
Affects protobufjs protobuf.jsSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 8.0.2 or 7.5.6 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.0.2, 7.5.6, 8.0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade protobuf.js to 8.0.2 or 7.5.6; protobufjs/protobuf.js to 8.0.3 or 7.5.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| protobufjsprotobuf.js | Affected
| Fixed in
|
| protobufjsprotobuf.js | Affected
| Fixed in
|
npmprotobufjs/protobuf.jspkg:npm/protobufjs/protobuf.jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrading protobuf.js to version 7.5.6 or later (for the 7.x series) or to version 8.0.2 or later (for the 8.x series) resolves this vulnerability. Patch status is not explicitly stated in the vendor advisory, but the description confirms the issue is fixed in these versions. Users should update to these fixed versions to mitigate the risk. No additional mitigation steps are indicated.
Description
protobuf.js versions prior to 7.5.6 and between 8.0.0 and 8.0.2 contain a vulnerability in their UTF-8 decoding implementation. The minimal UTF-8 decoder accepted overlong UTF-8 byte sequences and decoded them to canonical characters instead of replacing them. This behavior may allow an attacker to bypass application-level checks that inspect raw bytes before protobuf string decoding.