CVE-2026-44312: premailer css_parser · Untrusted Functionality Inclusion
Affects premailer css_parserSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium : upgrade to 2.1.0 or 1.22.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.0, 1.22.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade css_parser to 2.1.0 or 1.22.0; css_parser to 1.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| premailercss_parser | Affected
| Fixed in
|
| premailercss_parser | Affected
| Fixed in
|
RubyGemscss_parserpkg:gem/css_parserOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade css_parser to version 2.1.0 or later, or 1.22.0 or later, where proper HTTPS certificate validation is implemented. No other mitigations are indicated as the vulnerability is fixed in these versions. Patch status is confirmed by the vendor advisory stating the fix is included in these releases.
Description
css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.
References
- github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc (opens in a new tab)
- github.com/premailer/css_parser/issues/185 (opens in a new tab)
- github.com/premailer/css_parser/commit/35e689c904225add78e0c488cf04bad052666449 (opens in a new tab)
- github.com/premailer/css_parser/commit/e0c95d5abe91b237becb90ff316531a6547ada18 (opens in a new tab)