CVE-2026-44423: shellhub · Insecure Direct Object Reference
Affects shellhubSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.24.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.24.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade shellhub and shellhub-io/shellhub to 0.24.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| shellhub-ioshellhub | Affected
| Fixed in
|
GitHubshellhub-io/shellhubpkg:github/shellhub-io/shellhubOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ShellHub to version 0.24.2 or later, where this authorization bypass vulnerability has been fixed. Until upgraded, restrict access to trusted users only and monitor for unauthorized access attempts. Patch status is not explicitly confirmed beyond the version fix statement; check vendor sources for current remediation guidance.
Description
ShellHub versions prior to 0.24.2 contain an authorization bypass vulnerability where authenticated users can access full session objects belonging to other tenants. This allows reading sensitive session details such as SSH usernames, device UIDs, remote IPs, terminal types, authentication flags, and timestamps without proper tenant scoping. The issue is addressed in version 0.24.2.