Skip to main content
VulnerabilityPublished

CVE-2026-44451: prolix-oc Lumiverse · Protection Mechanism Failure

Affects prolix-oc LumiverseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.9.7 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Lumiverse and prolix-oc/Lumiverse to 0.9.7.

Affected software

ProductAffectedFixed in
prolix-ocLumiverseAffected
  • <0.9.7
Fixed in
  • 0.9.7
GitHubprolix-oc/Lumiversepkg:github/prolix-oc/LumiverseOther threatsAffected
  • <0.9.7
Fixed in
  • 0.9.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Lumiverse version 0.9.7. Users and administrators should upgrade to version 0.9.7 or later to remediate this issue. There is no official vendor advisory provided here, but the description explicitly states the fix is in 0.9.7. Until upgrading, users should avoid importing or enabling untrusted theme packs or component overrides.

Description

CVE-2026-44451 is a critical protection mechanism failure in the Lumiverse AI chat application prior to version 0.9.7. The vulnerability arises from the component override system that transpiles user-supplied TSX code and evaluates it in a sandbox intended to block dangerous globals. However, both the static source validator and runtime sandbox controls can be bypassed, allowing reconstruction of blocked identifiers and escape to the real window object via DOM references. Exploitation requires a victim to import a malicious theme pack and enable a component override, which then executes code in their authenticated session. This vulnerability is fixed in Lumiverse version 0.9.7.

References

Community reviews

Loading reviews…