CVE-2026-44475: ellanetworks core · Improperly Implemented Security Check for Standard
Affects ellanetworks coreSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.10.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.10.0
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade core and ellanetworks/core to 1.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ellanetworkscore | Affected
| Fixed in
|
GitHubellanetworks/corepkg:github/ellanetworks/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Ella Core to version 1.10.0 or later, where this vulnerability is fixed. Patch status is confirmed by the vendor stating the issue is resolved in 1.10.0. No other mitigation or temporary workaround is indicated.
Description
Ella Core versions prior to 1.10.0 contain a vulnerability where the UE Security Capabilities received in NGAP PathSwitchRequest messages are not verified against locally stored values. This allows a malicious gNB to overwrite stored UE security capabilities with arbitrary values by sending a crafted PathSwitchRequest message. The vulnerability is fixed in version 1.10.0. The CVSS score is 6.1, indicating a medium severity issue with potential integrity and availability impacts but no confidentiality loss.