Skip to main content
VulnerabilityPublished

CVE-2026-44580: vercel next.js · Cross-site Scripting

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 16.2.5 or 15.5.16 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vercel next.js to 16.2.5 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=13.0.0 <15.5.16
Fixed in
  • 15.5.16

AI-suggested

Upgrade affected Next.js applications to version 15.5.16 or later in the 15.x branch, or 16.2.5 or later in the 16.x branch to apply the official fix. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified.

Description

Next.js versions from 13.0.0 up to but not including 15.5.16, and from 16.0.0 up to but not including 16.2.5, contain a cross-site scripting (XSS) vulnerability.

References

Community reviews

Loading reviews…