CVE-2026-44635: kysely · Path Traversal
Affects kyselySource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.28.17 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.28.17, 0.28.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade kysely to 0.28.17; kysely-org/kysely to 0.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kysely-orgkysely | Affected
| Fixed in
|
npmkysely-org/kyselypkg:npm/kysely-org/kyselyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Kysely version 0.28.17. Users should upgrade to version 0.28.17 or later to remediate this vulnerability. Since this is a library vulnerability, applying the official patch by upgrading is the recommended mitigation. Patch status is confirmed by the vendor advisory stating the issue is fixed in 0.28.17.
Description
Kysely versions from 0.26.0 up to 0.28.16 contain a path traversal vulnerability in the DefaultQueryCompiler.visitJSONPathLeg function. This flaw allows attacker-controlled input to manipulate JSON-path metacharacters, enabling traversal beyond intended JSON keys. Consequently, attackers can read and, in update statements, write to JSON sub-fields outside the developer's intended scope across MySQL, PostgreSQL, and SQLite databases. The vulnerability is fixed in version 0.28.