CVE-2026-44643: peerigon angular-expressions · Eval Injection
Affects peerigon angular-expressionsSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade peerigon angular-expressions to 1.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| peerigonangular-expressions | Affected
| Fixed in
|
npmangular-expressionspkg:npm/angular-expressionsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in peerigon angular-expressions version 1.5.2. Users and organizations should upgrade to version 1.5.2 or later to remediate this vulnerability. No vendor advisory content is provided, but the description explicitly states the issue is fixed in 1.5.2. Until upgrading, avoid using vulnerable versions in production environments.
Description
Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.