CVE-2026-44667: factionsecurity faction · Cross-site Scripting
Affects factionsecurity factionSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.8.3 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade faction and factionsecurity/faction to 1.8.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| factionsecurityfaction | Affected
| Fixed in
|
GitHubfactionsecurity/factionpkg:github/factionsecurity/factionOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FACTION to version 1.8.3 or later, where this stored XSS vulnerability has been fixed. Since the vendor advisory confirms the fix in 1.8.3, applying this official update is the recommended remediation. No other mitigation steps are specified or required.
Description
FACTION versions prior to 1.8.3 are affected by a stored cross-site scripting (XSS) vulnerability in the remediation verification file preview feature. The vulnerability arises because attachment filenames supplied by users are stored and rendered without proper output encoding, allowing attacker-controlled JavaScript to execute in the browsers of users who view these files. This persistent XSS can impact privileged users and lead to high confidentiality and integrity risks. The issue is fixed in version 1.8.3.