CVE-2026-44668: factionsecurity faction · Missing Authentication
Affects factionsecurity factionSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.8.3 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade faction and factionsecurity/faction to 1.8.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| factionsecurityfaction | Affected
| Fixed in
|
GitHubfactionsecurity/factionpkg:github/factionsecurity/factionOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to factionsecurity faction product version 1.8.3 or later, where this vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 1.8.3, applying this official fix is the recommended remediation. Patch status is confirmed by the vendor advisory stating the fix is included in version 1.8.3. No additional mitigations are specified.
Description
CVE-2026-44668 is a critical vulnerability in the factionsecurity faction product 'faction' prior to version 1.8.3. The issue arises because the AccessControlInterceptor, which is supposed to authenticate all Struts2 actions, does not verify session validity before invoking actions. Additionally, four methods in BoilerPlateConfig lack local session checks, allowing unauthenticated attackers to read, modify, deactivate, or delete boilerplate templates. This vulnerability has a CVSS score of 9.8, indicating a high risk of confidentiality, integrity, and availability impact. The vulnerability is fixed in version 1.8.3.