CVE-2026-44713: mcdope pam_usb · OS Command Injection
Affects mcdope pam_usbSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 0.8.7 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.7
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pam_usb and mcdope/pam_usb to 0.8.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mcdopepam_usb | Affected
| Fixed in
|
GitHubmcdope/pam_usbpkg:github/mcdope/pam_usbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pam_usb to version 0.8.7 or later, where this vulnerability is fixed. Until upgraded, restrict access to environments where $TMUX can be manipulated by untrusted users. Patch status is not explicitly confirmed by a vendor advisory, so check for official updates or vendor communications for the latest remediation guidance.
Description
pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, src/tmux.c reads the user's $TMUX environment variable, splits it on commas, and interpolates the socket-path component directly into a shell command passed to popen(). Because the value is placed inside double-quotes without sanitisation, any value containing " terminates the quoted string and injects arbitrary shell syntax.popen() runs as root inside the PAM stack. This vulnerability is fixed in 0.8.7.