CVE-2026-44715: org.openmrs.module:legacyui-api · Improper Authorization
Affects org.openmrs.module:legacyui-apiSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 2.10.0 or 1.23.0 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.0, 1.23.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.openmrs.module:legacyui-api and org.openmrs.module/legacyui-api to 2.10.0 or 1.23.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| openmrsorg.openmrs.module:legacyui-api | Affected
| Fixed in
|
| openmrsorg.openmrs.module:legacyui-api | Affected
| Fixed in
|
Mavenorg.openmrs.module/legacyui-apipkg:maven/org.openmrs.module/legacyui-apiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenMRS to version 1.23.0 or later, or 2.10.0 or later, where this improper authorization vulnerability is patched. No other mitigations are specified.
Description
OpenMRS is an open source electronic medical record system platform. Prior to versions 1.23.0 and 2.10.0, an authenticated user can trigger administrative DWR services. Specifically, the `startHl7ArchiveMigration` method is accessible, which should be restricted to admin-level accounts. Versions 1.23.0 and 2.10.0 patch the issue.