Skip to main content
VulnerabilityPublished Updated

CVE-2026-44727: jupyter_server · Cross-site Scripting

Affects jupyter_serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.20 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.20
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade jupyter_server and jupyter-server to 2.20.

Affected software

ProductAffectedFixed in
jupyter-serverjupyter_serverAffected
  • <2.20
Fixed in
  • 2.20
PyPIjupyter-serverpkg:pypi/jupyter-serverOther threatsAffected
  • <2.20
Fixed in
  • 2.20

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Jupyter Server is the backend for Jupyter web applications. Prior to 2.20, the nbconvert HTTP handlers in jupyter_server render user-authored notebook HTML under the Jupyter origin without a sandbox directive in their Content-Security-Policy. Combined with nbconvert.HTMLExporter's default non-sanitizing behavior, a notebook carrying an HTML payload in a display_data output triggers stored XSS with cookie access, full /api/* authority, and kernel RCE. This vulnerability is fixed in 2.20.

References

Community reviews

Loading reviews…