CVE-2026-44839: rabbitmq-server · Basic XSS
Affects rabbitmq-serverSource CVE Database V5
Not known to be exploited · CVSS 5.6 Medium : upgrade to 4.1.2 or 4.0.13 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.2, 4.0.13
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade rabbitmq-server to 4.1.2 or 4.0.13; rabbitmq/rabbitmq-server to 4.0.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected RabbitMQ-server installations to version 4.0.13 or later, or 4.1.2 or later, where this vulnerability is fixed. Patch status is not explicitly confirmed beyond the fixed version numbers; check the vendor advisory for current remediation details before deployment.
Description
CVE-2026-44839 is a medium severity vulnerability in rabbitmq-server versions from 3.7.0 up to but not including 4.0.13, and from 4.1.0-alpha up to but not including 4.1.2. It involves improper neutralization of script-related HTML tags, classified as CWE-80, which is a basic cross-site scripting (XSS) vulnerability.