Skip to main content
VulnerabilityPublished

CVE-2026-44843: langchain · Deserialization of Untrusted Data

Affects langchainSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 1.3.3 or 0.3.85 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.3, 0.3.85
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade langchain to 1.3.3 or 0.3.85; langchain to 0.3.85.

Affected software

ProductAffectedFixed in
langchain-ailangchainAffected
  • >=1.0.0a1 <1.3.3
Fixed in
  • 1.3.3
langchain-ailangchainAffected
  • <0.3.85
Fixed in
  • 0.3.85
PyPIlangchainpkg:pypi/langchainOther threatsAffected
  • <0.3.85
Fixed in
  • 0.3.85

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading LangChain to version 0.3.85 or later, or 1.3.3 or later, fully addresses this vulnerability. No other official remediation or temporary fixes are documented. Users should apply these updates to ensure the vulnerability is mitigated.

Description

LangChain versions prior to 0.3.85 and between 1.0.0a1 and before 1.3.3 contain a deserialization vulnerability. The framework uses overly broad allowlists when deserializing certain runtime inputs, allowing trusted LangChain-serializable objects to be instantiated with untrusted constructor arguments. This can lead to unintended object instantiation during deserialization. The vulnerability is identified as CWE-502 and has a high severity with a CVSS score of 8.

References

Community reviews

Loading reviews…