Skip to main content
VulnerabilityPublished

CVE-2026-44844: GOVCERT-LU eml_parser · Uncontrolled Recursion

Affects GOVCERT-LU eml_parserSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 3.0.1 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade eml_parser and eml-parser to 3.0.1.

Affected software

ProductAffectedFixed in
GOVCERT-LUeml_parserAffected
  • <3.0.1
Fixed in
  • 3.0.1
PyPIeml-parserpkg:pypi/eml-parserOther threatsAffected
  • <3.0.1
Fixed in
  • 3.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in eml_parser version 3.0.1. Users should upgrade to version 3.0.1 or later to remediate this issue. No other mitigation or workaround is indicated. Patch status is not explicitly confirmed in the vendor advisory, but the description states the issue is fixed in 3.0.1, which should be considered the official fix.

Description

CVE-2026-44844 is a medium severity vulnerability in the GOVCERT-LU eml_parser Python module prior to version 3.0.1. The vulnerability arises from uncontrolled recursion in the get_raw_body_text() function, which recurses without depth limits on nested message/rfc822 attachments. An attacker supplying a crafted EML file with about 120 nested parts can trigger a RecursionError, causing the parser to crash. The exploit requires a non-RFC-compliant EML file, making it an unlikely scenario. This issue is fixed in version 3.0.1.

References

Community reviews

Loading reviews…