Skip to main content
VulnerabilityPublished

CVE-2026-44899: lepture mistune · Cross-site Scripting

Affects lepture mistuneSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.7 Medium : upgrade to 3.2.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade lepture mistune to 3.2.1.

Affected software

ProductAffectedFixed in
lepturemistuneAffected
  • <3.2.1
Fixed in
  • 3.2.1
PyPImistunepkg:pypi/mistuneOther threatsAffected
  • <3.2.1
Fixed in
  • 3.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade mistune to version 3.2.1 or later where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated in vendor advisory content but the description confirms the fix is in 3.2.1.

Description

CVE-2026-44899 is a cross-site scripting (XSS) vulnerability in the lepture mistune Python Markdown parser prior to version 3.2.1. The issue arises from improper validation of the :width: and :height: options in the Image directive plugin, where a regex only partially validates numeric input, allowing additional CSS to be injected into style attributes without escaping. This vulnerability allows an attacker to inject arbitrary CSS into rendered HTML. The vulnerability is fixed in version 3.2.1. The CVSS score is 4.7, indicating a medium severity level.

References

Community reviews

Loading reviews…