Skip to main content
VulnerabilityPublished Updated

CVE-2026-44900: oviva-ag epa4all-client · Improper Certificate Validation

Affects oviva-ag epa4all-clientSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 1.2.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.1
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade epa4all-client and oviva-ag/epa4all-client to 1.2.1.

Affected software

ProductAffectedFixed in
oviva-agepa4all-clientAffected
  • <1.2.1
Fixed in
  • 1.2.1
com.oviva.telematikepa4all-clientAffected
  • <1.2.1
Fixed in
  • 1.2.1
Mavenoviva-ag/epa4all-clientpkg:maven/oviva-ag/epa4all-clientOther threatsAffected
  • <1.2.1
Fixed in
  • 1.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in epa4all-client version 1.2.1. Users should upgrade to version 1.2.1 or later to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the updated client version. Patch status beyond this is not explicitly stated in the vendor advisory, so users should verify with official vendor sources for the latest guidance.

Description

CVE-2026-44900 is a high-severity vulnerability in oviva-ag's epa4all-client Java client prior to version 1.2.1. The vulnerability arises because the method SignedPublicKeysTrustValidatorImpl.isTrusted() fails to verify the result of the ECDSA signature check, effectively trusting any structurally valid signature. Although the method performs certificate chain validation and OCSP checks, it does not confirm that the signature actually matches, leading to improper certificate validation. This flaw could allow an attacker to bypass signature verification, impacting confidentiality and integrity. The issue is fixed in version 1.2.1.

References

Community reviews

Loading reviews…