CVE-2026-44902: open-telemetry opentelemetry-js · Improper Handling of Exceptional Conditions
Affects open-telemetry opentelemetry-jsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.217.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.217.0, 0.75.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade opentelemetry-js and exporter-prometheus and sdk-node to 0.217.0; auto-instrumentations-node to 0.75.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| open-telemetryopentelemetry-js | Affected
| Fixed in
|
| @opentelemetryexporter-prometheus | Affected
| Fixed in
|
| @opentelemetrysdk-node | Affected
| Fixed in
|
| @opentelemetryauto-instrumentations-node | Affected
| Fixed in
|
npmopentelemetry-jspkg:npm/opentelemetry-jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade opentelemetry-js to version 0.217.0 or later, where this vulnerability is fixed.
Description
CVE-2026-44902 is a high-severity vulnerability in the OpenTelemetry JavaScript client (opentelemetry-js) versions prior to 0.217.0. The issue arises because the Prometheus metrics endpoint lacks proper error handling for malformed HTTP requests, specifically invalid URIs. This causes an uncaught TypeError that crashes the Node.js process running the exporter. The vulnerability has been fixed in version 0.217.0.