Skip to main content
VulnerabilityPublished

CVE-2026-44972: DataDog guarddog · Improper Encoding or Escaping of Output

Affects DataDog guarddogSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.0 Medium : upgrade to 2.9.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade DataDog guarddog to 2.9.1.

Affected software

ProductAffectedFixed in
DataDogguarddogAffected
  • >=2.6.0 <=2.9.0
Fixed in–
PyPIguarddogpkg:pypi/guarddogOther threatsAffected
  • >=2.6.0 <2.9.1
Fixed in
  • 2.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when analyzing untrusted PyPI packages with affected GuardDog versions. Consider running GuardDog in isolated environments or with output redirection to mitigate potential terminal manipulation.

Description

GuardDog is a CLI tool to identify malicious PyPI packages. From 2.6.0 to 2.9.0, GuardDog includes attacker-controlled filenames, file locations, messages, and code snippets in its default human-readable output without escaping terminal control characters. A malicious package can therefore inject ANSI or OSC escape sequences into analyst terminals or CI logs.

References

Community reviews

Loading reviews…