CVE-2026-44985: amir20 dozzle · Origin Validation Error
Affects amir20 dozzleSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 10.5.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.5.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade dozzle and amir20/dozzle to 10.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| amir20dozzle | Affected
| Fixed in
|
GitHubamir20/dozzlepkg:github/amir20/dozzleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Dozzle to version 10.5.2 or later, where the origin validation issue in the WebSocket upgrader is fixed. No other mitigations are indicated. Patch status is not explicitly confirmed in vendor advisory content, but the fix is stated to be in version 10.5.2.
Description
Dozzle versions prior to 10.5.2 contain an origin validation vulnerability in the WebSocket upgrader for the /exec and /attach endpoints. The CheckOrigin function accepts requests from any origin, combined with a JWT cookie set with SameSite: Lax, enabling Cross-Site WebSocket Hijacking (CSWSH). An attacker on a same-site origin can exploit this to gain interactive shell access to containers accessible by the victim. This vulnerability is fixed in version 10.5.2.