Skip to main content
VulnerabilityPublished

CVE-2026-44991: OpenClaw · Incorrect Authorization

Affects OpenClawSource GCVE Database

0

Not known to be exploited · CVSS 2.3 Low : upgrade to 2026.4.21 when convenient.

Data as of 27 Oct 2026, 00:42 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.4.21
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenClaw to 2026.4.21.

Affected software

ProductAffectedFixed in
OpenClaw OpenClawAffected
  • <2026.4.21
Fixed in
  • 2026.4.21

AI-suggested

If you cannot patch yet, administrators should avoid configuring wildcard inbound senders without explicit owner allowFrom settings to prevent unauthorized command execution.

Description

OpenClaw versions before 2026.4.21 have an authorization bypass vulnerability in the command-auth.ts component. This flaw allows non-owner users to execute commands that should be restricted to owners, such as /send, /config, or /debug, when wildcard inbound senders are configured without explicit owner allowFrom settings. The vulnerability enables bypassing owner-only command authorization checks.

References

Community reviews

Loading reviews…