CVE-2026-45003: OpenClaw · Confused Deputy
Affects OpenClawSource GCVE Database
Not known to be exploited · CVSS 4.1 Medium : upgrade to 2026.4.22 when convenient.
Data as of 27 Oct 2026, 00:42 UTC
- Patch
- Available – fixed in 2026.4.22
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade OpenClaw to 2026.4.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenClaw OpenClaw | Affected
| Fixed in
|
AI-suggested
A fixed version is indicated as 2026.4.22 or later, so upgrading OpenClaw to version 2026.4.22 or newer will remediate this vulnerability. Until patched, restrict workspace access to trusted users only to reduce risk of exploitation.
Description
CVE-2026-45003 is a medium severity vulnerability in OpenClaw before version 2026.4.22. It allows attackers with workspace access to override connector endpoint hosts for Matrix, Mattermost, IRC, and Synology connectors by modifying workspace dotenv files. This can redirect runtime traffic to malicious endpoints, resulting in an unintended proxy or 'confused deputy' scenario.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-55cf-xx38-4p9p (opens in a new tab)
- github.com/openclaw/openclaw/commit/0623079e98abf7202591f1b04a89755eb7ec9272 (opens in a new tab)
- vulncheck.com/advisories/openclaw-connector-endpoint-host-override-via-workspace-dotenv-files (opens in a new tab)