Skip to main content
VulnerabilityPublished

CVE-2026-45006: OpenClaw · Incomplete List of Disallowed Inputs

Affects OpenClawSource GCVE Database

0

Not known to be exploited · CVSS 7.7 High : upgrade to 2026.4.23 soon.

Data as of 27 Oct 2026, 00:26 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.4.23
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenClaw to 2026.4.23.

Affected software

ProductAffectedFixed in
OpenClaw OpenClawAffected
  • <2026.4.23
Fixed in
  • 2026.4.23

AI-suggested

If you cannot patch yet, restrict access to the gateway tool's config.apply and config.patch operations and monitor for unauthorized configuration changes.

Description

OpenClaw versions before 2026.4.23 have an improper access control vulnerability in the gateway tool's config.apply and config.patch operations. This flaw allows compromised models to bypass an incomplete denylist and make unsafe configuration changes. These malicious modifications can persist across restarts and impact command execution, network behavior, credentials, and operator policies.

References

Community reviews

Loading reviews…