Skip to main content
VulnerabilityPublished Updated

CVE-2026-45261: gitbutlerapp gitbutler · Code Injection

Affects gitbutlerapp gitbutlerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.19.7 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gitbutler and gitbutlerapp/gitbutler to 0.19.7.

Affected software

ProductAffectedFixed in
gitbutlerappgitbutlerAffected
  • <0.19.7
Fixed in
  • 0.19.7
GitHubgitbutlerapp/gitbutlerpkg:github/gitbutlerapp/gitbutlerOther threatsAffected
  • <0.19.7
Fixed in
  • 0.19.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitButler to version 0.19.7 or later, where this vulnerability is fixed. Users who have not enabled forge integration are not vulnerable and do not require immediate action. Patch status is not explicitly stated in the vendor advisory, but the description confirms the issue is fixed in version 0.19.7.

Description

GitButler is a modern Git-based version control interface for AI-powered workflows. Prior to 0.19.7, a emote code execution vulnerability exists in the Tauri-based GitButler desktop application. An attacker can inject a malicious link in a pull request body, which if clicked by the user allows for arbitrary script execution in the Tauri webview. Users that have not enabled forge integration are not at risk. This vulnerability is fixed in 0.19.7.

References

Community reviews

Loading reviews…