Skip to main content
VulnerabilityPublished

CVE-2026-45281: nextcloud security-advisories · Insecure Direct Object Reference

Affects nextcloud security-advisoriesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 33.0.3 or 32.0.9 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 33.0.3, 32.0.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade security-advisories and nextcloud/server to 33.0.3 or 32.0.9.

Affected software

ProductAffectedFixed in
nextcloudsecurity-advisoriesAffected
  • >=33.0.0 <33.0.3
Fixed in
  • 33.0.3
nextcloudsecurity-advisoriesAffected
  • >=32.0.0 <32.0.9
Fixed in
  • 32.0.9
GitHubnextcloud/serverpkg:github/nextcloud/serverOther threatsAffected
  • >=32.0.0 <32.0.9
  • >=33.0.0 <33.0.3
Fixed in
  • 32.0.9
  • 33.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until then, restrict access to authenticated users and limit exposure of principal URLs if possible.

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, with the knowledge of other users’ principal URL an attacker could possibly send a request to gain full access to their calendar. Therefore, the attacker must be an authenticated user. This is because of improper authorization controls in the backend of the calendar. If the attacker had access to the calendar, they would be able to view and modify it. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17, 27.1.11.26, 26.0.13.26, 25.0.13.29, 24.0.12.34, 23.0.12.35, 22.2.10.39, or 21.0.9.23

References

Community reviews

Loading reviews…