CVE-2026-45293: WordPress-Coding-Standards · Eval Injection
Affects WordPress-Coding-StandardsSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 3.4.1 soon.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade WordPress-Coding-Standards to 3.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WordPressWordPress-Coding-Standards | Affected
| Fixed in
|
AI-suggested
A fix is available in WordPress Coding Standards version 3.4.1. Users should upgrade to version 3.4.1 or later to remediate this vulnerability. Until upgraded, avoid scanning untrusted PHP code with the WordPress or WordPress-Extra rulesets that include the vulnerable sniff. The WordPress-Core and WordPress-Docs rulesets are not affected and can be used as alternatives if scanning untrusted code is necessary.
Description
WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.
References
- github.com/WordPress/WordPress-Coding-Standards/security/advisories/GHSA-3pwp-g2mj-5p3v (opens in a new tab)
- github.com/WordPress/WordPress-Coding-Standards/pull/2771 (opens in a new tab)
- github.com/WordPress/WordPress-Coding-Standards/commit/a29048d0bbef5cf25d42349c74e4072d3cbc8325 (opens in a new tab)
- github.com/WordPress/WordPress-Coding-Standards/releases/tag/3.4.1 (opens in a new tab)