CVE-2026-45323: jpettitt meshcore-card · Cross-site Scripting
Affects jpettitt meshcore-cardSource CVE Database V5
Not known to be exploited · CVSS 9.6 Critical : upgrade to 0.3.3 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.3.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade meshcore-card and jpettitt/meshcore-card to 0.3.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jpettittmeshcore-card | Affected
| Fixed in
|
GitHubjpettitt/meshcore-cardpkg:github/jpettitt/meshcore-cardOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade meshcore-card to version 0.3.3 or later where this vulnerability is fixed. Since the vendor has released a fixed version, applying this official update is the recommended remediation. No additional mitigations are indicated by the vendor advisory.
Description
CVE-2026-45323 is a critical cross-site scripting (XSS) vulnerability in the jpettitt meshcore-card for Home Assistant. Versions prior to 0.3.3 render meshcore node names without proper HTML escaping, enabling any node within radio range to execute arbitrary JavaScript in the frontend of users viewing the card. This vulnerability allows an attacker to compromise confidentiality, integrity, and availability of the affected system. The issue is fixed in version 0.3.3.