Skip to main content
VulnerabilityPublished

CVE-2026-45328: espressif esp-idf · Improper Input Validation

Affects espressif esp-idfSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical · fixed in 5.5.5 : patch espressif esp-idf as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
espressifesp-idfAffected
  • =5.5.4
  • =6.0
Fixed in–
GitHubespressif/esp-idfpkg:github/espressif/esp-idfOther threatsAffected
  • =5.5.4
  • =6.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade esp-idf to versions 5.5.5 or 6.0.1 or later to remediate this vulnerability. No additional mitigation steps are specified beyond applying the official patches.

Description

CVE-2026-45328 is a critical vulnerability in the Espressif IoT Development Framework (esp-idf) versions 5.5.4 and 6.0. It involves improper input validation in the esp_tee component, which exposes secure-service wrappers bridging calls from user applications to TEE-protected hardware peripherals and security features. This vulnerability has been patched in versions 5.5.5 and 6.0.1.

References

Community reviews

Loading reviews…