Skip to main content
VulnerabilityPublished Updated

CVE-2026-45388: OCaml-TLS versions before 2.1.0 have a

Source CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.1.0 : patch affected systems as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

If you cannot patch yet, avoid using vulnerable versions in security-critical environments or implement additional certificate validation checks externally if possible.

Description

OCaml-TLS versions before 2.1.0 have a vulnerability in the client implementation where insufficient checks are performed on server certificates. This flaw allows an attacker to impersonate a server using certificates that lack proper KeyUsage and ExtendedKeyUsage attributes for server authentication. The vulnerability is critical with a CVSS score of 9.1, indicating high impact on confidentiality and integrity without requiring privileges or user interaction.

References

Community reviews

Loading reviews…