CVE-2026-45412: 1Panel-dev MaxKB · Server-Side Request Forgery (SSRF)
Affects 1Panel-dev MaxKBSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.9.1 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade MaxKB and 1panel-dev/MaxKB to 2.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in
|
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MaxKB to version 2.9.1 or later, where this SSRF vulnerability is fixed. Since the vendor advisory confirms the fix in 2.9.1, applying this official update is the recommended remediation. No additional mitigation guidance is provided or required.
Description
CVE-2026-45412 is a Server-Side Request Forgery (SSRF) vulnerability in the open-source AI assistant MaxKB by 1Panel-dev. Versions prior to 2.9.1 allow authenticated users to supply arbitrary URLs via the work_flow_template.downloadUrl parameter, which the server fetches without validation or internal IP filtering. This can lead to unauthorized server-side requests. The vulnerability has a CVSS 4.0 score of 6.3 (medium severity). A fix is available in version 2.