Skip to main content
VulnerabilityPublished

CVE-2026-45617: harttle liquidjs · ReDoS

Affects harttle liquidjsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 10.26.0 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.26.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade harttle liquidjs to 10.26.0.

Affected software

ProductAffectedFixed in
harttleliquidjsAffected
  • <10.26.0
Fixed in
  • 10.26.0

AI-suggested

Upgrade to LiquidJS version 10.26.0 or later where this vulnerability is fixed. Until then, avoid processing untrusted input with the strip_html filter or implement external request rate limiting to reduce exposure. Patch status is not explicitly confirmed in the vendor advisory, but the fix is stated to be in version 10.26.0.

Description

LiquidJS versions 10.25.7 and below contain a vulnerability in the strip_html filter where a flawed regular expression causes quadratic backtracking. This leads to a ReDoS (Regular Expression Denial of Service) attack that can block the Node.js event loop and cause high CPU usage. The issue is triggered by input containing many unclosed <script, <style, or <!-- tokens. The vulnerability allows unauthenticated attackers to cause severe event-loop blocking and CPU saturation. The issue is fixed in version 10.26.0.

References

Community reviews

Loading reviews…