Skip to main content
VulnerabilityPublished Updated

CVE-2026-45760: Apache Camel K · (Externally Controlled Reference to a Resource in Another Sphere)

Affects Apache Camel KSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High · fixed in 2.10.1 : patch Apache Camel K soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.10.1, 2.9.2, 2.8.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Camel K and org.apache.camel/camel-k to 2.10.1, 2.9.2 or 2.8.1.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Camel KAffected
  • >=2.10.0 <2.10.1
Fixed in
  • 2.10.1
Apache Software FoundationApache Camel KAffected
  • >=2.9.0 <2.9.2
Fixed in
  • 2.9.2
Apache Software FoundationApache Camel KAffected
  • >=2.0.0 <2.8.1
Fixed in
  • 2.8.1
Mavenorg.apache.camel/camel-kpkg:maven/org.apache.camel/camel-kOther threatsAffected
  • 2.0.0 – 2.10.0
  • >=2.9.0 <2.9.2
  • >=2.10.0 <2.10.1
4 affected builds
Fixed in
  • 2.8.1
  • 2.9.2
  • 2.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Camel K to version 2.10.1, 2.9.2, or 2.8.1, which contain fixes for this vulnerability. Patch status is not explicitly stated as 'official-fix' in the vendor advisory content, but the recommendation to upgrade to these versions indicates that a fix is available. No additional mitigation steps are specified or required beyond applying the upgrade.

Description

(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace. This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.

References

Community reviews

Loading reviews…