Skip to main content
VulnerabilityPublished Updated

CVE-2026-46039: Linux kernel · rxgk: Fix potential integer overflow in length check

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.17.0-1019.19~24.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1019.19~24.04.1, 6.17.0-1020.22~24.04.1, 6.17.0-40.40~24.04.1 +18
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-27.27?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-27.27
Fixed in
  • 7.0.0-27.27
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1007.7?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released updated Linux kernel packages that fix this vulnerability. After applying the update, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow the vendor's update instructions and ensure all kernel modules are compatible with the new kernel version.

Description

A high severity vulnerability (CVE-2026-46039) in the Linux kernel's rxgk subsystem was fixed by correcting a potential integer overflow in the length check within the rxgk_extract_token() function. The flaw involved improper rounding that could cause an overflow when validating ticket lengths. This issue affects multiple Linux kernel versions prior to 6.17.0-1026.26 and others as listed. The vulnerability has been patched in updated Linux kernel releases. Users are advised to update their systems and reboot to apply the fix.

References

Community reviews

Loading reviews…