Skip to main content
VulnerabilityPublished Updated

CVE-2026-46081: Linux kernel · crypto: acomp – fix wrong pointer stored by acomp_save_req()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 7.0.0-28.28~24.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-27.27, 7.0.0-1008.8 +6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-27.27
Fixed in
  • 7.0.0-27.27
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Linux kernel versions to resolve this vulnerability. The fix corrects the pointer stored by acomp_save_req() to prevent memory corruption during asynchronous crypto operations. Users should update their Linux kernel to the fixed versions as provided by their distribution's security advisories, such as Ubuntu Security Notice USN-8488-1. No additional mitigations are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's crypto subsystem (acomp) was fixed where acomp_save_req() stored an incorrect pointer, leading to memory corruption during asynchronous request completion. This flaw could cause a general protection fault when using asynchronous hardware implementations like the QAT driver with DMA virtual address interfaces. The issue has been resolved by correcting the pointer stored and simplifying related functions. This vulnerability affects multiple Linux kernel versions and has a CVSS score of 7.8, indicating a high severity impact on confidentiality, integrity, and availability. A patch is available as part of the Linux kernel updates.

References

Community reviews

Loading reviews…