CVE-2026-46093: Linux kernel · mm/vmalloc: take vmap_purge_lock in shrinker
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 7.0.0-1010.10 : patch Linux kernel soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-27.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
A patch is available and has been released by Ubuntu as part of updated Linux kernel packages. Users should apply the standard system update and reboot their systems to ensure the fix is applied. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the vendor advisory instructions for updating to the fixed package versions corresponding to your Ubuntu release and kernel flavor.
Description
A race condition vulnerability in the Linux kernel's memory management subsystem (mm/vmalloc) was resolved. The issue involved concurrent invocation of decay_va_pool_node() without proper serialization, leading to potential race conditions and memory leaks. This vulnerability affects multiple versions of the linux-hwe-edge kernel prior to specific 7.0.0 series releases. The vulnerability has a CVSS score of 7.8, indicating a high impact on confidentiality, integrity, and availability. A patch is available and included in updated Linux kernel packages distributed by Ubuntu. Users are advised to update and reboot their systems to apply the fix.
References
- nvd.nist.gov/vuln/detail/CVE-2026-46093 (opens in a new tab)
- git.kernel.org/stable/c/12f2341b4c235d5593a433abac201c1c6725787f (opens in a new tab)
- git.kernel.org/stable/c/687ccdf582169cd680aeaf24cc953807c4cd4345 (opens in a new tab)
- git.kernel.org/stable/c/c15ff206ba78820bf2873d0c668a882e99f4b631 (opens in a new tab)
- git.kernel.org/stable/c/ec05f51f1e65bce95528543eb73fda56fd201d94 (opens in a new tab)
- ubuntu.com/security/CVE-2026-46093 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-46093 (opens in a new tab)
- git.kernel.org/linus/ec05f51f1e65bce95528543eb73fda56fd201d94 (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8489-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8507-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8569-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)