CVE-2026-46096: Linux kernel · tpm2-sessions: Fix missing tpm_buf_destroy() in tpm2_read_public()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-27.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
An official patch is available and should be applied by updating the Linux kernel to the fixed versions listed in the Ubuntu security advisory USN-8488-1 and USN-8489-1. After applying the update, a system reboot is required to complete remediation. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. No additional mitigation steps are necessary beyond applying the official update.
Description
A vulnerability in the Linux kernel's TPM2 sessions subsystem was fixed by adding missing calls to tpm_buf_destroy() in the tpm2_read_public() function. The flaw caused a memory leak due to failure to release allocated buffers on certain code paths. This issue affects multiple versions of the linux-hwe-edge kernel prior to specific 7.0.0 releases. The vulnerability has a medium severity score and does not impact confidentiality or integrity but can cause availability issues due to resource leaks. A patch is available and should be applied to affected systems.
References
- nvd.nist.gov/vuln/detail/CVE-2026-46096 (opens in a new tab)
- git.kernel.org/stable/c/2f434be87e256fd58254f60ddf5d7d58e775ca0b (opens in a new tab)
- git.kernel.org/stable/c/f0f75a3d98b7959a8677b6363e23190f3018636b (opens in a new tab)
- git.kernel.org/stable/c/f8775d9d9062da662cc861f9ff7722a65896d4cd (opens in a new tab)
- ubuntu.com/security/CVE-2026-46096 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-46096 (opens in a new tab)
- git.kernel.org/linus/f0f75a3d98b7959a8677b6363e23190f3018636b (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8489-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8488-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8507-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8569-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)