Skip to main content
VulnerabilityPublished Updated

CVE-2026-46119: Linux kernel · libceph: Fix slab-out-of-bounds access in auth message processing

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-46119· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 3.13.0-214.265 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.13.0-214.265, 4.4.0-1156.162, 4.4.0-283.317~14.04.1 +90
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-27.27?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-27.27
Fixed in
  • 7.0.0-27.27
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1007.7?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms that the issue is fixed in updated Linux kernel packages. Users should update their Linux kernel to the fixed versions listed in the advisory and reboot the system to apply the changes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation steps are indicated beyond applying the official fix.

Description

A high severity vulnerability (CVE-2026-46119) in the Linux kernel's libceph component was fixed. The flaw involved a slab-out-of-bounds access during authentication message processing, where a positive result value was incorrectly treated as an error size, leading to out-of-bounds memory access and potential leakage of memory content. The issue was resolved by correcting the interpretation of the result field and adding additional checks. This vulnerability affects numerous Linux kernel versions prior to the fixed releases. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…