Skip to main content
VulnerabilityPublished Updated

CVE-2026-46199: Linux kernel · drm/amdgpu/vcn4: Prevent OOB reads when parsing dec msg

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-46199· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 6.8.0-1061.64~22.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1061.64~22.04.1, 6.8.0-1063.71~22.04.1, 6.8.0-1062.69~22.04.1 +44
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28
Fixed in
  • 7.0.0-28.28
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1003.4
Fixed in
  • 7.0.0-1003.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed kernel versions are available and should be applied. The vulnerability is resolved in Linux kernel versions 6.8.0-1061.62~22.04.1 and later for the affected Ubuntu HWE edge releases. Users should upgrade to these or later kernel versions to mitigate the issue. No additional mitigation steps are required beyond applying the official updates.

Description

A vulnerability in the Linux kernel's drm/amdgpu/vcn4 component allowed out-of-bounds (OOB) reads when parsing decode messages due to improper bounds checking against the buffer object. This issue has been resolved in updated kernel versions. The flaw could lead to information disclosure and denial of service. The vulnerability has a CVSS score of 7.1, indicating medium severity. Fixed versions are available in the Linux kernel 6.8.0-1061.62 and later for the affected Ubuntu HWE edge releases.

References

Community reviews

Loading reviews…