Skip to main content
VulnerabilityPublished

CVE-2026-46442: FlowiseAI Flowise · Code Injection

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · 36% EPSS · CVSS 9.4 Critical : upgrade to 3.1.2 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
36.3% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Flowise and flowiseai/flowise to 3.1.2.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.2
Fixed in
  • 3.1.2
npmflowiseai/flowisepkg:npm/flowiseai/flowiseOther threatsAffected
  • <3.1.2
Fixed in
  • 3.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.2 or later, where this vulnerability is patched. Until upgrading, restrict access to the POST /api/v1/node-custom-function endpoint to trusted users only and configure E2B_APIKEY to enable additional security controls if possible. Patch status is confirmed as fixed in version 3.1.2.

Description

FlowiseAI Flowise versions prior to 3.1.2 contain a critical code injection vulnerability in the POST /api/v1/node-custom-function endpoint. This endpoint lacks route-level authorization, allowing any authenticated user or API key to submit arbitrary JavaScript code. When the E2B_APIKEY is not configured, the submitted code executes inside a NodeVM sandbox that can be escaped, enabling attackers to execute system commands on the host. This results in authenticated remote code execution on the Flowise server host. The vulnerability is patched in version 3.1.2.

References

Community reviews

Loading reviews…