CVE-2026-46447: OpenStack Ironic · Incorrect Resource Transfer Between Spheres
Affects OpenStack IronicSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium · fixed in 35.0.2 : update OpenStack Ironic when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 35.0.2, 32.0.2, 29.0.6 +1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Ironic to 35.0.2, 32.0.2, 29.0.6 or 26.1.7; openstack/ironic to 35.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenStackIronic | Affected
| Fixed in
|
| OpenStackIronic | Affected
| Fixed in
|
| OpenStackIronic | Affected
| Fixed in
|
| OpenStackIronic | Affected
| Fixed in
|
PyPIopenstack/ironicpkg:pypi/openstack/ironicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Since the vulnerability affects versions prior to 35.0.2, upgrading to version 35.0.2 or later is likely the intended remediation once available. Until an official fix is confirmed, restrict access to node.driver_info and node.instance_info settings to trusted administrators only to reduce risk.
Description
OpenStack Ironic before 35.0.2 allows Boot Script Injection of an iPXE script if the attacker can set node.driver_info or node.instance_info.