Skip to main content
VulnerabilityPublished Updated

CVE-2026-46478: FlowiseAI Flowise · Mass Assignment

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 3.1.2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Flowise and flowiseai/flowise to 3.1.2.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.2
Fixed in
  • 3.1.2
npmflowiseai/flowisepkg:npm/flowiseai/flowiseOther threatsAffected
  • <3.1.2
Fixed in
  • 3.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.2 or later, where this vulnerability has been patched. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the vendor stating the fix in version 3.1.2.

Description

FlowiseAI Flowise versions prior to 3.1.2 contain a vulnerability where the DatasetRow create and update functionality allows mass-assignment that can lead to cross-workspace row takeover. This issue is classified under CWE-915, indicating improper control of dynamically-determined object attributes. The vulnerability has been fixed in version 3.1.2.

References

Community reviews

Loading reviews…