Skip to main content
VulnerabilityPublished

CVE-2026-46497: apify crawlee-python · Server-Side Request Forgery (SSRF)

Affects apify crawlee-pythonSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 1.7.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade apify crawlee-python to 1.7.0.

Affected software

ProductAffectedFixed in
apifycrawlee-pythonAffected
  • >=1.0.0 <1.7.0
Fixed in
  • 1.7.0
PyPIcrawlee-pythonpkg:pypi/crawlee-pythonOther threatsAffected
  • >=1.0.0 <1.7.0
Fixed in
  • 1.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Crawlee is a web scraping and browser automation library. From version 1.0.0 to before version 1.7.0, Crawlee is vulnerable to SSRF via sitemap-derived URLs. This issue has been patched in version 1.7.0.

References

Community reviews

Loading reviews…